MainRadiotalkCustom
Общие вопросы по интернет радио вещанию
4   •   Посмотреть все темы

Проблема с настройкой Icecast

 

20
Kerker @Kerker
Нужно сделать интернет радио. ОС стоит CentOS 5.6 поставил туда всё что нужно начал настраивать вроде всё по мануалу сделал а выскакивает:
Error during send: Mount failed on ********** , error: Login failed.

Конфиг Icecast
Показать текст


Конфиг Ices
Показать текст


Подскажите плиз в чём проблема.

6245
Тарас @tarasian666
другим источником подключиться пробовали?

20
Kerker @Kerker
в смысле внешним или как?

6245
Тарас @tarasian666
любым

20
Kerker @Kerker
пробовал через рилэй ко внешнему всё равно ничего не играет. Да даже меняю в ices порт допустим на 9500 оно мне всё равно выдаёт эту ошибку.

6245
Тарас @tarasian666
Icecast точно работает? Страница статуса отображаеться?

20
Kerker @Kerker
да всё отображает. Вообще не могу понять в чём трабл.

6245
Тарас @tarasian666
пробуйте отключить iptables

20
Kerker @Kerker
всё равно ту же ошибку выкидывает.

20
Kerker @Kerker
Ну что может кто подсказать в чём проблема?

20
Kerker @Kerker
Вот достал лог ошибок с icecast
Показать текст


пишет что пароль не правильный, но по настройкам вроде всё верно. Подскажите в чём проблема?

1572
KyPIIaToB @KyPIIaToB
значит не верный

Добавлено спустя 6 минут 46 секунд:
У тебя в конфиге не понятно, фалбак сам на себя в маунте, хрень какая то.
На вот поправь для себя конфиг и попробуй

<icecast>
<limits>
<clients>100</clients>
<sources>2</sources>
</limits>
<authentication>
<relay-password>******</relay-password>
<source-password>******</source-password>
<admin-user>******</admin-user>
<admin-password>******</admin-password>
</authentication>

<directory>
<yp-url-timeout>15</yp-url-timeout>
<yp-url>http://dir.xiph.org/cgi-bin/yp-cgi</yp-url>
</directory>

<hostname>localhost</hostname>
<listen-socket>
<port>8000</port>
</listen-socket>

<mount>
<mount-name>/ices</mount-name>
<password>******</password>
</mount>

<fileserve>1</fileserve>
<paths>
<logdir>./logs</logdir>
<webroot>./web</webroot>
<adminroot>./admin</adminroot>
<alias source="/" dest="/status.xsl"/>
</paths>
<logging>
<accesslog>access.log</accesslog>
<errorlog>error.log</errorlog>
<loglevel>2</loglevel> <!-- 4 Debug, 3 Info, 2 Warn, 1 Error -->
<logsize>200000</logsize> <!-- Max size of a logfile -->
<logarchive>1</logarchive>
</logging>
</icecast>

Отредактировано KyPIIaToB - 29.05.2011
20
Kerker @Kerker
Теперь это пишет Error during send: Mount failed on ********** , error: Couldn't connect.

Может ли быть проблема из-за того что настройка производится на виртуальной машине в Virtualbox который стоит на Windows 7??

727
Leff27 @Leff27
в первом конфиге
<changeowner>
<user>icecast</user>
<group>icecast</group>
</changeowner>

А должно стоять вроде как
<changeowner>
<user>nobody</user>
<group>nogroup</group>
</changeowner>

Kerker пишет:

Теперь это пишет Error during send: Mount failed on ********** , error: Couldn't connect.

Может ли быть проблема из-за того что настройка производится на виртуальной машине в Virtualbox который стоит на Windows 7??

Не может подключиться, проверь название маунтов, пароли и порты... в конфигах icecast2 и ices

20
Kerker @Kerker
Да по 100 раз проверял всё в порядке. А то что ты указал я создал группу всё как по мануалу.

6245
Тарас @tarasian666
Kerker пишет:

Может ли быть проблема из-за того что настройка производится на виртуальной машине в Virtualbox который стоит на Windows 7??

я обычно ноборот делаю, запускаю винду под линуксом )
на виртуал боксе из под линукса запускал фряху, icecast и ices работали без проблем. Так что проблема не в виртуалбоксе
Leff27 пишет:

в первом конфиге
        <changeowner>
            <user>icecast</user>
            <group>icecast</group>
        </changeowner>

А должно стоять вроде как
        <changeowner>
            <user>nobody</user>
            <group>nogroup</group>
        </changeowner>

не имеет значения от какого юзера запускать, главное не от рута и чтоб юзер существовал

может еще быть проблема когда редактировать конфиги обычным блокнотом в винде, желательно в той же среде редактором vi или nano

20
Kerker @Kerker
tarasian666 пишет:

может еще быть проблема когда редактировать конфиги обычным блокнотом в винде, желательно в той же среде редактором vi или nano

чёт я вот это не совсем понял под линуском недавно работаю можешь объяснить как тугодуму)

6245
20
Kerker @Kerker
я через MC редактировал всегда.

20
Kerker @Kerker
Поставили всё на основной сервер к глубокому удивлению заработало так до сих пор и не понял в чём проблема былла.
Счас новый попрос появился как я понимаю icecast название трека и артиска берет из идз а можно как нибудь сделать что бы всё бралось просто из плэйлиста?
И ещё если при проигрывании радио я буду изменять плэйлист как будет вести себя радио?