MainRadiotalkCustom
Технологии вещания, софт, скрипты
4   •   Посмотреть все темы

Айскаст матерится, если его в автостарт запихиваешь

 

183
levbazhenov @levbazhenov
Есть Вин 7.
На нём айскаст, установлен как виндоус сервайс. (в конце установки галочка).
захотели сделать, что бы он при запуске компа сразу же запускался. запихнули в автостарт.
делаем тест. перезагружаем комп.
айскаст открывается, и пишет что то вро де: фатал еррор, не парсит конфиг файл. ну и вот как бы.
если после этого выключить айскаст (и через Диспетчер З. вырубить IcecastServise, по крайней мере я и его выключаю), и снова запустить его, то всё ок.

что это такое?

6245
Тарас @tarasian666
в автостарте видимо не установлен путь к конфигу

183
levbazhenov @levbazhenov
в автостарт копируем exe файл запуска айскаста.
как же туда установить этот путь?

6245
Тарас @tarasian666
посмотрите в ярлык

183
levbazhenov @levbazhenov
посмотрели. что то не понятно))

183
levbazhenov @levbazhenov
Попробовал у себя установить айс, установил программу AutoRunMen, через него добавил в авторан Icecast2win.exe.
Выключаюсь. Включаюсь. Вылетает окно с текстом: "Unable to load config file (.\icecast.xml) unable to start.
Нажимаем ОК. Открывается окошко айскаста.
Пробую "старт сервер". Окно: Error с текстом "error parsing config file (.\icecast.xml)". Нажимаю ОК. следующее окно. "XML config parsing error". ОК. и следующее: "Unable to start sever".

Закрываю окно айскаста, следовательно, выключаю его.

Запускаю айскаст через ярлык. сервер стартовал как надо.


вот как бы.

6245
Тарас @tarasian666
Icecast2win.exe -с C:\Proram files и тд путь к\icecast.xml
в ярлыке или так или просто еще указана рабочая папка

183
levbazhenov @levbazhenov
Можете по подробнее сказать? Я в этом деле очень плох.

6245
Тарас @tarasian666
непомню как в винде но на *nix он запускаеться только с указанием конфига
попробуйте из командной строки запустить C:\Proram files...путь к\Icecast2win.exe -с C:\Proram files и тд путь к\icecast.xml
если запуститься то в автостарт надо будет подобное написать

183
levbazhenov @levbazhenov
неа не работает

183
levbazhenov @levbazhenov
Может кто ещё сталкивался с этим?

63
Андрей @rw6hrm
Ни разу. Машины под ХР Хома/Про, никогда проблем не было.
Реально можно в автостарт и не запихивать, раз как сервис запустился, то и тот же Оддкаст к нему запросто коннектится.

183
levbazhenov @levbazhenov
Проблема уже давно решена, просто напросто перетаскиванием уже готового ярлыка с раб. стола посредством SCP.