MainRadiotalkCustom
Общие вопросы по интернет радио вещанию
6   •   Посмотреть все темы

icecast2+ices0/icegenerator задержки при воспроизведении

 

2
blackhat @blackhat
Система:FreeBSD 6.3
ПО: icecast2+ices0/icegenerator и shoutcast+sc_trans
Проблема: Когда используется связка "shoutcast+sc_trans" то все работает отлично, радио проигрывается без задержек и пр. Когда же включаешь icecast2+ices0/icegenerator, через каждые секунд 5-7 воспроизведение останавливается на примерно такой же промежуток и затем снова возобновляется. Вот мои конфиги:

-------------- icecast.xml --------------<icecast>
<limits>
<clients>10</clients>
<sources>7</sources>
<threadpool>12</threadpool>
<queue-size>1572864</queue-size>
<client-timeout>30</client-timeout>
<header-timeout>15</header-timeout>
<source-timeout>600</source-timeout>
<burst-on-connect>1</burst-on-connect>
<burst-size>262140</burst-size>
</limits>

<authentication>
<source-password>qwerty123</source-password>
<relay-password>qwerty123</relay-password>
<admin-user>admin</admin-user>
<admin-password>qwerty123</admin-password>
</authentication>

<hostname>Main Stream</hostname>
<listen-socket>
<port>8000</port>
<bind-address>6x.xxx.x.xx9</bind-address>
</listen-socket>
<fileserve>1</fileserve>

<paths>
<basedir>/usr/local/share/icecast</basedir>
<logdir>/var/log/icecast</logdir>
<webroot>/usr/local/share/icecast/web</webroot>
<adminroot>/usr/local/share/icecast/admin</adminroot>
<alias source="/" dest="/status.xsl"/>
</paths>

<logging>
<accesslog>access.log</accesslog>
<errorlog>error.log</errorlog>
<loglevel>4</loglevel>
<logsize>10000</logsize>
</logging>

<security>
<chroot>0</chroot>
<changeowner>
<user>nobody</user>
<group>nobody</group>
</changeowner>
</security>
</icecast>

-------------- ices.conf --------------<?xml version="1.0"?>
<ices:Configuration xmlns:ices="http://www.icecast.org/projects/ices">
<Playlist>
<File>play.txt</File>
<Randomize>1</Randomize>
<Type>builtin</Type>
<Module>ices</Module>
<Crossfade>5</Crossfade>
</Playlist>
<Execution>
<Background>1</Background>
<Verbose>0</Verbose>
<BaseDirectory>/tmp</BaseDirectory>
</Execution>
<Stream>
<Server>
<Hostname>6x.xxx.x.xx9</Hostname>
<Port>8000</Port>
<Password>qwerty123</Password>
<Protocol>http</Protocol>
</Server>
<Mountpoint>/ices</Mountpoint>
<Name>Default stream</Name>
<Genre>Default genre</Genre>
<Description>Default description</Description>
<URL>http://6x.xxx.x.xx9:8000/</URL>
<Public>0</Public>
<Bitrate>128</Bitrate>
<Reencode>0</Reencode>
<Channels>2</Channels>
</Stream>
</ices:Configuration>

-------------- icegenerator.conf --------------IP=6x.xxx.x.xx9
PORT=8000
SERVER=2
MOUNT=/r
SOURCE=source
PASSWORD=qwerty123
FORMAT=1
MP3PATH=pth:/home/xxx/files
RECURSIVE=1
DUMPFILE=
LOOP=1
SHUFFLE=1
NAME=Main Stream
GENRE=other
DESCRIPTION=bla bla bla
URL=http://6x.xxx.x.xx9:8000/mp3.pls
BITRATE=128
PUBLIC=0
METAUPDATE=5
LOG=2
LOGPATH=/var/log/icecast/icegenerator.log
DATAPORT=

Так же если смотреть в соединениях компа, на котором прослушиваешь радио, то коннект к радио пропадает и затем снова появляется. То есть, соединяется с радио - скачивает кусок песни, отключается и так по кругу :).
С интернет-соединением что дома, что на серваке где крутится радио все нормально - проверял пингом, закачкой и др. Процессы icecast2 и ices0 в топе постянно есть.
В чем может быть трабл?)

Добавлено спустя 5 минут 9 секунд:
решение оказалось простым до невозможности ....
<Reencode>0</Reencode> надо установить в 1
получается если битрейт песни не совпадает с битрейтом указанным в настройках будут такие проблемы

2
blackhat @blackhat
:) но вот что странно ... играло после перезагрузки минут 10 нормально и в данный момент снова тормозит ...ничего не понимаю