MainRadiotalkCustom
Общие вопросы по интернет радио вещанию
6   •   Посмотреть все темы

Помочь в установке и связке liquidsoap и icecast

 

888
Falcon @Falcon
insun пишет:

Чтобы не плодить темы пишу сюда.
Установил icecast2 и liquidsoap. При попытке запуска liquidsoap пишет init: security exit, root euid (user)
Сервер icecast2 работает, а с liquidsoap проблема. Ставил из репозитория. deb-multimedia в репозиториях есть.

Запускать надо не от пользователя root, а от другого.

36
insun @insun
При запуске от простого пользователя liquidsoap вылетает с сообщением:
init: exception encountered during start phase:
Sys_error("/var/log/liquidsoap/radio.log: Permission denied")

В этот файл логи писались при попытках запуска из под рута, а теперь, я так понимаю, доступ программе туда запрещен. Думаю, файл лога нужно переносить в домашнюю директорию. А где в настройках liquidsoap менять файл лога?

36
insun @insun
Спасибо за помощь. Запустил liquidsoap. Вывод логов в файл прописал в файле сценария, с которым liquidsoap запускается:
# техническая папка

tech = "/home/user/radio/log"

# логи

set("log.file.path","#{tech}/liquidsoap.log") # путь к файлу лога

set("log.level", 3) # уровень логирования


Возник следующий вопрос: как заставить liquidsoap работать в фоновом режиме, например, как nginx? И сервер работает, и у юзера доступ к linux есть. Сейчас liquidsoap запускается, и пока не остановишь, приглашение bash не появляется. То есть, юзер ничего делать не может в системе.

Отредактировано insun - 13.01.2014
888
Falcon @Falcon
liquidsoap -d путь_к_конфигу

36
insun @insun
Так liquidsoap не создает и не получает доступ к файлу /var/run/liquidsoap/radio.pid

Я поступил проще. Запустил как написано на сайте разработчика на странице Interaction with the server - **********:
sudo /etc/init.d/liquidsoap start
и убрал в файле конфигурации строки:
# техническая папка

tech = "/home/user/radio/log"

# логи

set("log.file.path","#{tech}/liquidsoap.log") # путь к файлу лога

set("log.level", 3) # уровень логирования

Чтобы liquidsoap обращался к стандартному файлу лога

Теперь liquidsoap запущен из-под рута каналом radio.liq, имеет доступ к стандартному файлу логов и стандартному файлу демона. К которым он должен обращаться по умолчанию. И, если пользователь отключается от сервера, liquidsoap теперь не отваливается, то есть, работает в режиме демона (или сервера).

Только в плейлисте нужно прописать пути не от домашней директории, а от корня. Иначе муз-файлы не находит.

Falcon, большое спасибо. Наталкиваешь на нужные решения.

Но теперь новые грабли - периодически на секунду-две прерывается воспроизведение в проигрывателе. Думаю, прерывается поток. До этого при работе связки Icecast2+Icecs не прерывался. Думаю, вопрос не в icecast2, а в liquidsoap.

И почему-то в статусе icecast2 - Current Song: Unknown

Отредактировано insun - 14.01.2014
22
Ярослав @EnigmA_MaN_1
tarasian666 пишет:

^M - похоже там лишний нечитабельный знак

в конфиге в первой строчке #!/usr/bin/liquidsoap - после liquidsoap поставте пробел и проблема с /usr/bin/liquidsoap^M: bad interpreter: No such file or directory

1
oldboy @oldboy
Здравствуйте.
А можно liquidsoap поставить на centos 7?
Что-то порпобовал стандартным методом -
yum -y install liquidsoap
А он мне говорит. что нет такого пакета.
И даже на офсайте liquidsoap в списке под скачивание есть фрибсд, убунту, винда и т.д., а про центос молчок....

Отредактировано oldboy - 02.05.2015
89
Ok_go_love @Ok_go_love
oldboy пишет:

Здравствуйте.
А можно liquidsoap поставить на centos 7?
Что-то порпобовал стандартным методом -
yum -y install liquidsoap
А он мне говорит. что нет такого пакета.
И даже на офсайте liquidsoap в списке под скачивание есть фрибсд, убунту, винда и т.д., а про центос молчок....

Соберите сами из source.

6245
Тарас @tarasian666

а про центос молчок

только собирать из исходников и не только liquidsoap, а много его зависимостей, поэтому и нет в списке centOS на оф сайте и я настоятельно рекомендую не использовать эту ос для мультимедийных целей (это возможно, но очень геморно)

35
pixel @pixel
Falcon пишет:

Запускать надо не от пользователя root, а от другого.

А под каким пользователем нужно запускать? При установки мыла юзер сам создастся? Или нужно создавать вручную? Если вручную, так может и устанавливаться мыло должно сразу под другим юзером а не под рутом?

35
pixel @pixel
Ну подскажите как устанавливать то? Попытался с гитхаба клонировать, на make init получаю:
~/liquidsoap# make init
git fetch
git branch --set-upstream-to=origin/master master
error: unknown option `set-upstream-to=origin/master'
usage: git branch [options] [-r | -a] [--merged | --no-merged]
or: git branch [options] [-l] [-f] <branchname> [<start-point>]
or: git branch [options] [-r] (-d | -D) <branchname>
or: git branch [options] (-m | -M) [<oldbranch>] <newbranch>

Generic options
-v, --verbose be verbose
-t, --track set up tracking mode (see git-pull(1))
--set-upstream change upstream info
--color[=<when>] use colored output
-r act on remote-tracking branches
--contains <commit> print only branches that contain the commit
--abbrev[=<n>] use <n> digits to display SHA-1s

Specific git-branch actions:
-a list both remote-tracking and local branches
-d delete fully merged branch
-D delete branch (even if not merged)
-m move/rename a branch and its reflog
-M move/rename a branch, even if target exists
-l create the branch's reflog
-f, --force force creation (when already exists)
--no-merged <commit> print only not merged branches
--merged <commit> print only merged branches

make: *** [init] Error 129

посмотрел файл install - установил библиотеки, которые там описаны но ничего не изменилось. Помогите!

382
Grigorij @gyurgin_1
Да что Вы мучаететсь, не умеете - ставьте из репозитория.
По данной ошибке - нужно обновить git.
Пользователь подойдет любой из группы sudo и audio (если планируется играть на звуковую карту), под ним же и собирать (make install естественно под root).
Все темы уже смотрю переворошили, спрашивали бы в одной и давали ссылку что берете и откуда.

35
pixel @pixel
gyurgin_1 пишет:

Да что Вы мучаететсь, не умеете - ставьте из репозитория.

лучше один раз сделать правильно, чем 10 раз переделывать.
gyurgin_1 пишет:

По данной ошибке - нужно обновить git.

Либо я не знаю как обновлять либо:
Reading package lists... Done
Building dependency tree
Reading state information... Done
git is already the newest version.
git set to manually installed.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

gyurgin_1 пишет:

Пользователь подойдет любой из группы sudo и audio (если планируется играть на звуковую карту), под ним же и собирать (make install естественно под root).

Значит юзера делать вручную. На звуковую плату пока не планирую выводить.
gyurgin_1 пишет:

Все темы уже смотрю переворошили, спрашивали бы в одной и давали ссылку что берете и откуда.

ну так раз ни в одной теме не отвечают - бегаю и ищу.
Пока что имею debian 6 (если рекомендуете другую ОС - мне поменять не сложно), с установленным icecast по ********** ссылке, но пока ничего там не настраивал. Решил поставить мыло, читал, что лучше из исходников, вот и пытаюсь по ********** ссылке.

Отредактировано pixel - 15.10.2015
382
Grigorij @gyurgin_1
Git насколько я помню нужен версии 1.8.3 и выше, на этот debian можно попробовать поставить **********
Насколько я понял предполагается играть AAC+ в броузере, тогда icecast берем ********** - без вариантов. И хватит поднимать темы столетней давности - большая часть описанного там уже история.

35
pixel @pixel
gyurgin_1 пишет:

Git насколько я помню нужен версии 1.8.3 и выше, на этот debian можно попробовать поставить **********
Да, я заметил, что версия гита старовата
gyurgin_1 пишет:

Насколько я понял предполагается играть AAC+ в броузере, тогда icecast берем ********** - без вариантов.
А если не только aac+? а еще и mp3 потребуется - эта ссылка подойде?
gyurgin_1 пишет:

И хватит поднимать темы столетней давности - большая часть описанного там уже история.

вот и я о том же, как можно настроить современную систему по мануалам 6-летней давности. Ну а дебиан 6 то подойдет? может другое что поставить? цент ос, говорят, не стоит, а убунту сам не хочу.

382
Grigorij @gyurgin_1
Icecast KH все что надо Вам странслирует, насчет Debian 6 я бы призадумался, совсем уж древняя версия, с Centos да - намучаетесь, Debian Jessie или Ubuntu, с последней кстати все будет намного проще.

35
pixel @pixel
ну давайте тогда попробуем убунту. какую версию лучше брать и стоит ли ставить desktop? ведь в принципе то наверное лучше минимал ставить и без лишних гуев. или я ошибаюсь?

382
Grigorij @gyurgin_1
Да нафиг нужен десктоп то, серверную Ubuntu 14.04.3 LTS ставьте и все.

35
pixel @pixel
ок. начинаю стаскивать дистр

35
pixel @pixel
gyurgin_1 пишет:

Насколько я понял предполагается играть AAC+ в броузере, тогда icecast берем ********** - без вариантов.

Наверное глупый вопрос, но в описании есть следующее:
icecast requires the following packages :

* libxml2 - **********
* libxslt - **********
* curl - ********** (>= version 7.10 required)
NOTE: icecast may be compiled without curl, however this will
disable all Directory server interaction (YP).
* ogg/vorbis - ********** (>= version 1.0 required)

их нужно ставить до установки айскаста? (наверное да). И еще, а как по вашей ссылке устанавливать? ну то что клон сабвершион - это понятно, а дальше как?