MainRadiotalkCustom
Общие вопросы по интернет радио вещанию
6   •   Посмотреть все темы

Ices и Perl (Debian Lenny)

 

9
Okashimaru @Okashimaru
Дело такое - при ./configure Ices пишет Perl - no
Но при попытке "apt-get install perl-dev" мне пишут:

Depends: libfaad2 but it is not installable
Depends: libmp4v2-0 (>= 1:1.6dfsg) but it is not going to be installed
Depends: libperl5.10 (>= 5.10.1) but 5.10.0-19lenny5 is to be installed
Depends: libpython2.6 (>= 2.6) but it is not installable
Depends: libxml2 (>= 2.7.4) but 2.6.32.dfsg-5+lenny5 is to be installed
Что делать :)

6245
Тарас @tarasian666
на форум линукс
искать разрешение зависимостей

если не помогло apt-get update

9
Okashimaru @Okashimaru
Update не помог. Кстати почему-то perl-dev пакет в репозитории не видит (apt-get install perl-dev)

6245
Тарас @tarasian666
apt-get search perl
и увидите все что есть, может немного не так называется

9
Okashimaru @Okashimaru
tarasian666
Спасибо большое) Помогло разрешение зависимостей. Модуль libcurl3-gnutls libasound ices0 был в режиме HOLD, поэтому он не давал (не понимаю как) Ices дотянуться до perl. Помогло - apt-get -u dist-upgrage (вылез список модулей в режиме hold) которые я удалил. Переустановил Ices и все работает.